Commit dfd6e2b6 authored by van den Berg's avatar van den Berg
Browse files

Add conda environment file

parent ab72c170
......@@ -24,25 +24,14 @@ conda environments are no long available.
# Installation
To run this pipeline you will need the following at minimum:
* python 3.6
* snakemake 5.2.0 or newer
This repository contains a [conda](https://conda.io/docs/)
environment file that you can use to install all minimum dependencies in a
environment file that you can use to install all dependencies in a
conda environment:
```bash
conda env create -f environment.yml
```
Alternatively, you can set up a python virtualenv and run
```bash
pip install -r requirements.txt
```
## Singularity
We highly recommend the user of the containerized rules through
......
# This file may be used to create an environment using:
# $ conda env create --file environment.yml
# platform: linux-64
name: hutspot
channels:
- bioconda
- conda-forge
dependencies:
- pytest-workflow>=1.4.0
- snakemake-minimal>=5.22.1
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment